Code

Opened 2 years ago

Closed 2 years ago

#17894 closed Bug (duplicate)

create_template_postgis-debian.sh fails on Ubuntu 11.10

Reported by: jpaulett Owned by: nobody
Component: GIS Version: master
Severity: Normal Keywords:
Cc: john@… Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Ubuntu 11.10 upgraded to PostgreSQL 9.1, thus the path to the PostGIS files have changed again (to /usr/share/postgresql/9.1/contrib/postgis-1.5)

Additionally it appears that plpsql is now installed in the template database by default, resulting the failure of the createlang command, which causes following commands to not be executed:

createlang: language "plpgsql" is already installed in database "template_postgis"

On a fresh Ubuntu 11.10 install:

$ sudo -u postgres psql
psql (9.1.3)
Type "help" for help.

postgres=# \dL
      List of languages
  Name   |  Owner   | Trusted 
---------+----------+---------
 plpgsql | postgres | t
(1 row)

The attached patch adds the path to PostgreSQL 9.1 and only runs createlang for older version.

Attachments (1)

create-template-pg91.patch (1.1 KB) - added by jpaulett 2 years ago.
PG 9.1 support

Download all attachments as: .zip

Change History (3)

Changed 2 years ago by jpaulett

PG 9.1 support

comment:1 Changed 2 years ago by jpaulett

  • Cc john@… added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 2 years ago by claudep

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17584

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.