Code

Opened 2 years ago

Closed 14 months ago

#17826 closed Bug (wontfix)

Failures in Firefox+Windows 7+Admin filter tests

Reported by: ramiro Owned by: nobody
Component: contrib.admin Version: master
Severity: Normal Keywords:
Cc: charette.s@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by ramiro)

Ran the admin_widgets regression tests as of now are run with both the Firefox and Chrome Selenium drivers active.

Chrome tests run without errors, Firefox ones show two failures:

(selenium) C:\...\django\trunk\tests>python runtests.py --settings=test_sqlite admin_widgets
Creating test database for alias 'default'...
Creating test database for alias 'other'...
..........................................FF
======================================================================
FAIL: test_basic (regressiontests.admin_widgets.tests.HorizontalVerticalFilterSeleniumFirefoxTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "C:\...\django\trunk\tests\regressiontests\admin_widgets\tests.py", line 604, in test_basic
    [self.arthur, self.cliff, self.jason, self.john])
AssertionError: Lists differ: [<Student: Lisa>, <Student: Pe... != [<Student: Arthur>, <Student: ...

First differing element 0:
Lisa
Arthur

Second list contains 2 additional elements.
First extra element 2:
Jason

- [<Student: Lisa>, <Student: Peter>]

Versions:

  • Firefox: 10.0.2
  • selenium Python module: 2.20.0
  • Chrome: 17.0.963.56 m
  • Windows: 7 64 bits

Attachments (0)

Change History (6)

comment:1 follow-up: Changed 2 years ago by charettes

  • Cc charette.s@… added

Ran the tests with FF11 on ubuntu 12.04 64 bits and it works fine

(django-trunk)simon@simon-laptop:~/Developpement/django-trunk/tests$ ./runtests.py admin_widgets --settings=test_sqlite --liveserver=localhost:8082
Creating test database for alias 'default'...
Creating test database for alias 'other'...
......................................s.s..
----------------------------------------------------------------------
Ran 41 tests in 21.377s

OK (skipped=2)
Destroying test database for alias 'default'...
Destroying test database for alias 'other'...

Can you update your version and FF and see if it fixes it?

comment:2 Changed 2 years ago by ramiro

  • Description modified (diff)

comment:3 Changed 2 years ago by aaugustin

  • Triage Stage changed from Unreviewed to Accepted

This feature was rewritten in #13614, which should be committed any time. There's a non-negligible chance that this problem will be fixed as a side effect.

comment:4 in reply to: ↑ 1 Changed 2 years ago by ramiro

Replying to charettes:

Can you update your version and FF and see if it fixes it?

I'm unable to do that ATM but I forgot to report these tests pass on Debian Linux unstable (Debian's flavors of Firefox Iceweasel 10.0.2 and of Chrome engine Chromium browser 17.0.963.56 (Developer Build 121963 Linux))

Just wanted to leave a note about the failure on win32.

comment:5 Changed 14 months ago by joeri

Attempted to reproduce this bug on:

  • Windows 7 (64 bit)
  • Python 2.7 (32 bit)
  • Mozilla Firefox 19.0
  • Django master (Github SHA: #6000600cc5ef6f56cb8076034295b1cea144f569)
  • Selenium 2.30.0

And for reference:

  • Internet Explorer 9.0.8 (32 bit) IEDriverServer_Win32_2.30.2.zip
  • Chrome 25.0.1364.97 m chromedriver_win_26.0.1383.0.zip

Output:

(env) D:\Work\Projects\joeri\django\tests>python runtests.py --settings=test_sqlite admin_widgets
Creating test database for alias 'default'...
Creating test database for alias 'other'...
...................................................
----------------------------------------------------------------------
Ran 51 tests in 102.149s

OK
Destroying test database for alias 'default'...
Destroying test database for alias 'other'...

comment:6 Changed 14 months ago by charettes

  • Resolution set to wontfix
  • Status changed from new to closed

Marking as wontfix since FF 10.0.2 market shares on windows are not significant anymore and the issue is reported to be solved on FF 19.0.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.