Code

Opened 2 years ago

Closed 17 months ago

#17769 closed Cleanup/optimization (needsinfo)

RTL from in admin panel css

Reported by: shark4313@… Owned by: nobody
Component: contrib.auth Version: 1.3
Severity: Normal Keywords: rtl
Cc: adamzap@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: yes

Description

RTL form in admin panel didn't apply rtl.css code as it is overridden by Form.css code

I solved this by putting important to
.aligned label at line 157 in rtl.css as below :

.aligned label{

padding: 0 0 3px 1em;
float: right !important;

}

Attachments (3)

17769-django-1.3.png (51.8 KB) - added by adamzap 2 years ago.
Django 1.3
17769-django-1.3.1.png (51.9 KB) - added by adamzap 2 years ago.
Bug is in Django 1.3.1
17769-django-1.4.png (51.8 KB) - added by adamzap 2 years ago.
Bug is not in Django 1.4

Download all attachments as: .zip

Change History (7)

comment:1 Changed 2 years ago by jezdez

  • Easy pickings set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted
  • UI/UX set

Changed 2 years ago by adamzap

Django 1.3

Changed 2 years ago by adamzap

Bug is in Django 1.3.1

Changed 2 years ago by adamzap

Bug is not in Django 1.4

comment:2 Changed 2 years ago by adamzap

I tried reproducing this in multiple versions of Django, and it looks like it was fixed in 1.4. See screenshots:

  • No bug in 1.3
  • Bug in 1.3.1
  • No bug in 1.4

I believe this ticket can be closed...unless I am referring to the wrong bug.

comment:3 Changed 2 years ago by adamzap

  • Cc adamzap@… added

comment:4 Changed 17 months ago by EmilStenstrom

  • Resolution set to needsinfo
  • Status changed from new to closed

@shark4313 reports a bug with the labels (as indicated by the ".aligned label" CSS class). There's no indication what's wrong.

@adamzap then checks the differences between versions and according to the screen shoots the only difference is the input fields. The styling of the input fields have nothing to do with the labels.

I'm closing this bug as needsinfo. A screen shoot of what's wrong would be helpful.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.