Opened 3 years ago

Closed 3 years ago

#16784 closed Bug (invalid)

FormWizardWithNullBooleanField regression test failing

Reported by: adamnelson Owned by: nobody
Component: Forms Version: master
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

While running the regression tests with the default sqlite test, I get this error which is not on the ci server (http://ci.django-cms.org/job/Django/223/#showFailuresLink):

======================================================================
ERROR: testWizard (regressiontests.formwizard.tests.FormWizardWithNullBooleanField)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/adam/Development/yipit-env/src/django/tests/regressiontests/formwizard/tests.py", line 57, in testWizard
  File "/Users/adam/Development/yipit-env/src/django/django/test/client.py", line 439, in get
    response = super(Client, self).get(path, data=data, **extra)
  File "/Users/adam/Development/yipit-env/src/django/django/test/client.py", line 241, in get
    return self.request(**r)
  File "/Users/adam/Development/yipit-env/src/django/django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "/Users/adam/Development/yipit-env/src/django/django/utils/decorators.py", line 25, in _wrapper
    return bound_func(*args, **kwargs)
  File "/Users/adam/Development/yipit-env/src/django/django/utils/decorators.py", line 91, in _wrapped_view
    response = view_func(request, *args, **kwargs)
  File "/Users/adam/Development/yipit-env/src/django/django/utils/decorators.py", line 21, in bound_func
    return func(self, *args2, **kwargs2)
  File "/Users/adam/Development/yipit-env/src/django/django/contrib/formtools/wizard/legacy.py", line 127, in __call__
    return self.render(form, request, current_step)
  File "/Users/adam/Development/yipit-env/src/django/django/contrib/formtools/wizard/legacy.py", line 141, in render
    return self.render_template(request, form, ''.join(prev_fields), step, context)
  File "/Users/adam/Development/yipit-env/src/django/django/contrib/formtools/wizard/legacy.py", line 243, in render_template
    ), context_instance=RequestContext(request))
  File "/Users/adam/Development/yipit-env/src/django/django/shortcuts/__init__.py", line 20, in render_to_response
    return HttpResponse(loader.render_to_string(*args, **kwargs), **httpresponse_kwargs)
  File "/Users/adam/Development/yipit-env/src/django/django/template/loader.py", line 169, in render_to_string
    t = get_template(template_name)
  File "/Users/adam/Development/yipit-env/src/django/django/template/loader.py", line 145, in get_template
    template, origin = find_template(template_name)
  File "/Users/adam/Development/yipit-env/src/django/django/template/loader.py", line 138, in find_template
    raise TemplateDoesNotExist(name)
TemplateDoesNotExist: forms/wizard.html

----------------------------------------------------------------------
Ran 4132 tests in 374.402s

FAILED (errors=1, skipped=68, expected failures=3)

It looks like the culprit is https://github.com/django/django/commit/e708cf68a5fd44e24d6d6a03049807c9503285ae but I don't see why the tests are otherwise passing on the Jenkins machine.

Change History (1)

comment:1 Changed 3 years ago by adamnelson

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

Sorry about that - an old directory was deleted on the repository but not propagated to my environment.

Note: See TracTickets for help on using tickets.
Back to Top