Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16687 closed Bug (duplicate)

Several tests requiring internet fail on Ubuntu build machines

Reported by: barry@… Owned by: nobody
Component: Testing framework Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The following tests which require internet connection fail on the Ubuntu build machines. I've commented them out so that django can be built for Ubuntu. There should probably a better way to skip them when there's no internet, or write them so that external access isn't required.

  • test_urlfield_3
  • test_urlfield_4
  • test_correct_url_value_passes

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Yes, there are better ways -- we can and do use the @skipUnless and @skipIf decorators, and we use mock services when possible. In this case, nobody has got around to providing a patch that either skips/expected fails the test when there's no network connection, or provides a mock for urllib (or whatever needs to be mocked in this case).

A patch to do either of these would certainly be welcome; I'd probably prefer a mock to a skipped test, but I could live with either if a mock turns out to be too hard to achieve.

Also - this is the second report (c.f. #16686) where you've referred to "the" Ubuntu build machines. Which build machines are you referring to here?

comment:2 Changed 3 years ago by ramiro

Actually, we've solved this in trunk (see #16189 and [16451]. I haven't backported that to the 1.3.X (actually I'm not backporting anything except fixes for regressions introduced in the 1.3 development cycle).

comment:3 Changed 3 years ago by ramiro

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #16189.

comment:4 Changed 3 years ago by anonymous

These machines, which build packages from source for both the Ubuntu archive and PPAs.

https://launchpad.net/builders/

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.