Opened 5 years ago

Closed 5 years ago

#16562 closed Bug (duplicate)

intcomma now (incorrectly) requires USE_THOUSAND_SEPARATOR = True

Reported by: anonymous Owned by: nobody
Component: contrib.humanize Version: master
Severity: Release blocker Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Prior to r16168, the django.contrib.humanize intcomma filter, when used in a project with settings:

USE_L10N = True
USE_THOUSAND_SEPARATOR = False 
LANGUAGE_CODE = 'en-us'

would insert commas into numbers. After r16168, intcomma requires that USE_THOUSAND_SEPARATOR = True in order for it to insert the commas (or other separator for other languages, I'd guess). This is a regression and a bit non-sensical: if I'm specifically coding intcomma into my templates, it's a safe bet I do want the commas added, regardless of the USE_THOUSAND_SEPARATOR setting.

Change History (3)

comment:1 Changed 5 years ago by Chris Beaven

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Triage Stage: UnreviewedAccepted

comment:2 Changed 5 years ago by Bas Peschier

Marked #16558 as a duplicate as it describes a symptom.

comment:3 Changed 5 years ago by Malcolm Tredinnick

Resolution: duplicate
Status: newclosed

Looks like a dupe of #16404.

Note: See TracTickets for help on using tickets.
Back to Top