Opened 4 years ago

Closed 4 years ago

#16535 closed Bug (invalid)

UnicodeEncodeError

Reported by: direct@… Owned by: nobody
Component: contrib.admin Version: 1.3
Severity: Normal Keywords: codec
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by kmtracey)

TemplateSyntaxError at /admin/restaurant/restaurant/

Caught UnicodeEncodeError while rendering: 'ascii' codec can't encode characters in position 0-7: ordinal not in range(128)

Request Method: GET
Request URL: http://127.0.0.1:8000/admin/restaurant/restaurant/
Django Version: 1.3
Exception Type: TemplateSyntaxError
Exception Value: 

Caught UnicodeEncodeError while rendering: 'ascii' codec can't encode characters in position 0-7: ordinal not in range(128)

Exception Location: 	/usr/lib/python2.7/site-packages/virtualenv-1.6.1-py2.7.egg/ENVESHKIN/lib/python2.7/site-packages/Django-1.3-py2.7.egg/django/utils/functional.py in __str_cast, line 209
Python Executable: 	/usr/lib/python2.7/site-packages/virtualenv-1.6.1-py2.7.egg/ENVESHKIN/bin/python
Python Version: 	2.7.1
Python Path: 	

['/home/user/workspace/eshkin/eshkin',
 '/home/user/workspace/eshkin/eshkin',
 '/home/user/workspace/eshkin/eshkin',
 '/usr/lib/python2.7/site-packages/virtualenv-1.6.1-py2.7.egg/ENVESHKIN/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg',
 '/usr/lib/python2.7/site-packages/virtualenv-1.6.1-py2.7.egg/ENVESHKIN/lib/python2.7/site-packages/pip-1.0.1-py2.7.egg',
 '/usr/lib/python2.7/site-packages/virtualenv-1.6.1-py2.7.egg/ENVESHKIN/lib/python2.7/site-packages/Django-1.3-py2.7.egg',
 '/usr/lib/python2.7/site-packages/virtualenv-1.6.1-py2.7.egg/ENVESHKIN/lib/python2.7/site-packages/MySQL_python-1.2.3-py2.7-linux-i686.egg',
 '/usr/lib/python2.7/site-packages/virtualenv-1.6.1-py2.7.egg/ENVESHKIN/lib/python2.7/site-packages/PIL-1.1.7-py2.7-linux-i686.egg',
 '/usr/lib/python2.7/site-packages/virtualenv-1.6.1-py2.7.egg/ENVESHKIN/lib/python2.7/site-packages/docutils-0.8-py2.7.egg',
 '/usr/lib/python2.7/site-packages/virtualenv-1.6.1-py2.7.egg/ENVESHKIN/lib/python27.zip',
 '/usr/lib/python2.7/site-packages/virtualenv-1.6.1-py2.7.egg/ENVESHKIN/lib/python2.7',
 '/usr/lib/python2.7/site-packages/virtualenv-1.6.1-py2.7.egg/ENVESHKIN/lib/python2.7/plat-linux2',
 '/usr/lib/python2.7/site-packages/virtualenv-1.6.1-py2.7.egg/ENVESHKIN/lib/python2.7/lib-tk',
 '/usr/lib/python2.7/site-packages/virtualenv-1.6.1-py2.7.egg/ENVESHKIN/lib/python2.7/lib-old',
 '/usr/lib/python2.7/site-packages/virtualenv-1.6.1-py2.7.egg/ENVESHKIN/lib/python2.7/lib-dynload',
 '/usr/lib/python2.7',
 '/usr/lib/python2.7/plat-linux2',
 '/usr/lib/python2.7/lib-tk',
 '/usr/lib/python2.7/site-packages/virtualenv-1.6.1-py2.7.egg/ENVESHKIN/lib/python2.7/site-packages']

COMMENT: The error was discovered only at the opening of the administrative interface, please help

Change History (1)

comment:1 Changed 4 years ago by kmtracey

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

This trac is a place to report bugs/feature requests for Django. From the minimal amount of information presented here I'm guessing this is an error in one of your model's __unicode__ methods, not a bug in Django. Please post to django-users for help on how to fix your code. You will need to provide a bit more information about your code than you have here if you expect to get any useful help.

Also please use WikiFormatting and preview before posting here.

Note: See TracTickets for help on using tickets.
Back to Top