Code

Opened 3 years ago

Closed 3 years ago

#16522 closed Bug (duplicate)

ManyToManyField incorrectly assumes widget will always be SelectMultiple

Reported by: bendavis78 Owned by: nobody
Component: Forms Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

In django.db.models.fields.related, the ManyToManyField sets its help_text to "Hold down Control, or Command on a Mac, to select more than one." in init. This incorrectly makes the assumption that widget for this field will never be overridden (eg, when using CheckboxSelectMultiple). In order to override this widget, you must also override the help_text, which is less than ideal. It becomes especially tedious when overriding widgets in admin forms.

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by julien

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #9321.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.