Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#1633 closed enhancement (duplicate)

Allow including javascript files from different hosts in admin-interface.

Reported by: Rudolph Froger Owned by: Adrian Holovaty
Component: contrib.admin Version: magic-removal
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Currently the admin interface only allows one to include javascript files from the MEDIA_URL. If my project is on http://www.example.com/ and my media files are at http://media.example.com/, I can only server javascript from http://media.example.com/[ADMIN_MEDIA_PREFIX]/. Some javascript files require the be on the same hostname as your project, currently this isn't possible. It would be very nice if this would be possible:

class MyModel(models.Model):
    ...
    class Admin:
        js = ('js/example.js', 'http://www.example.com/js/other_example.js',)

Change History (3)

comment:1 Changed 10 years ago by bp@…

I think this is a duplicate of ticket #1099 , which was closed/wontfix

comment:2 Changed 10 years ago by Tom Tobin <korpios@…>

Resolution: duplicate
Status: newclosed

Duplicate of #1099 -- but even so, I'd like to see something along the lines of the patch in #1099 go in, since it's an easy, small fix and it's been three months since #1099 was closed without the "proper" fix materializing.

comment:3 Changed 10 years ago by Adrian Holovaty

milestone: Version 0.93

Milestone Version 0.93 deleted

Note: See TracTickets for help on using tickets.
Back to Top