Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#16243 closed Bug (fixed)

model_forms tests won't run if PIL isn't installed

Reported by: Julien Phalip Owned by: nobody
Component: Testing framework Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The model_forms tests won't run due to an import error if PIL isn't installed since the changes in [16358]. See attached patch.

Attachments (1)

16243.model_forms-pil-tests.diff (1.6 KB) - added by Julien Phalip 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by Julien Phalip

comment:1 Changed 5 years ago by Marcus Fredriksson

Triage Stage: UnreviewedReady for checkin

Confirmed. The attached patch fixes the problem for me.

comment:2 Changed 5 years ago by Russell Keith-Magee

Resolution: fixed
Status: newclosed

In [16391]:

Fixed #16243 -- Corrected test suite failure in model_forms when PIL isn't installed

comment:3 Changed 5 years ago by Russell Keith-Magee

Apologies to Julien for neglecting to credit him in the commit message.

Note: See TracTickets for help on using tickets.
Back to Top