Opened 4 years ago

Closed 3 years ago

#16237 closed Bug (duplicate)

Auth docs point to old function generic views instead of generic CBV

Reported by: rasca Owned by: nobody
Component: Documentation Version: master
Severity: Normal Keywords: class based views generic
Cc: preston@… Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

In https://docs.djangoproject.com/en/dev/topics/auth/#limiting-access-to-generic-views there's a mention on how to decorate the old generic views.

It should be about the new CBV since the old views are now deprecated. Also a mention of https://docs.djangoproject.com/en/dev//topics/class-based-views/#decorating-the-class would be in place.

Change History (3)

comment:1 Changed 4 years ago by melinath

  • Keywords class based views generic added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 3 years ago by ptone

  • Cc preston@… added

comment:3 Changed 3 years ago by timo

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17390 which has a patch.

Note: See TracTickets for help on using tickets.
Back to Top