Code

Opened 8 years ago

Closed 6 years ago

#1621 closed defect (duplicate)

manytomany admin widget broken under IE6.0 when in collapsed group

Reported by: Olive Owned by: xian
Component: contrib.admin Version:
Severity: normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

when your uncollapse the first time then the right list show only one
entry (in fact it is a dropdown at this stage).

If you save without performing any other operation before, then only
the shown entry will saved in the database (others entries will be LOST
!).

I you move one or more entry from a list to the other then the normal
widget appearance is restored and a subsequent save operation works as
expected.

Attachments (0)

Change History (10)

comment:1 Changed 8 years ago by ubernostrum

  • priority changed from highest to normal
  • Severity changed from blocker to normal

I'll take a look at this tomorrow and see if I can't roll a fix into the pending Django/Dojo stuff. Meanwhile, I don't think this is really a "highest priority" or "blocker" level of bug if it's gone the entire time from Django's original development at World Online a couple years ago and through eight months of public poking and prodding without anyone else catching it.

comment:2 Changed 8 years ago by anonymous

Hi,
Thank you for taking care of this.
If I can use Django/Dojo stuff then it will no more a blocker for me.
Could you please tell me how to integrate Django/Dojo ? (I'm sittting on MR branch)

comment:3 Changed 8 years ago by Olive

Reading the Wiki page about Ajax I realised that some Dojo widgets are already use in Admin MR branch.
Is M2M a Dojo widget ?

comment:4 Changed 8 years ago by adrian

Olive: No. Dojo isn't being used for anything in Django yet.

comment:5 Changed 8 years ago by Olive

OK, for now I will avoid collapsable groups :_(
Thanks for all Adrian.

comment:6 Changed 8 years ago by Gustavo

I added a line to django/contrib/admin/media/js/CollapsedFieldsets.js

        if (collapsed_seen) {
            // Expand all collapsed fieldsets when form is submitted.
            addEvent(findForm(document.getElementsByTagName('fieldset')[0]), 'submit', function() { CollapsedFieldsets.uncollapse_all(); });
        }
        CollapsedFieldsets.uncollapse_all();           // <----------------------------------------------
    },

I worked, but the page loads with the fieldsets uncollapsed now.

comment:7 Changed 7 years ago by Gary Wilson <gary.wilson@…>

  • Triage Stage changed from Unreviewed to Accepted

comment:8 Changed 7 years ago by ubernostrum

  • Owner changed from nobody to xian

Reassigning to xian since he's doing JS stuff for newforms-admin.

comment:9 Changed 6 years ago by garcia_marc

This one looks like a duplicate of #3110.

Could somebody check if that is true, and close as duplicate one?

comment:10 Changed 6 years ago by Karen Tracey <kmtracey@…>

  • Resolution set to duplicate
  • Status changed from new to closed

This, #3110, and #7278 are all reporting the same problem. Confirmed still a problem with IE6 (but not IE7) on newforms-admin r7737. Keeping #3110 open since it's got the right release/tags.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.