Opened 4 years ago

Closed 4 years ago

#16190 closed Cleanup/optimization (duplicate)

django.views.debug.technical_500_response() not much helpful for AJAX request

Reported by: zimnyx Owned by: nobody
Component: Core (Other) Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: yes

Description

When DEBUG=True and exception is raised inside a view, Django generates complete HTML page with exception info.
For AJAX requests it's not much readable (redundant CSS, <head>, etc.), it would be nice if there is another template for AJAX, which returns some simplified HTML or event text which can be than displayed to developer.

Change History (3)

comment:1 Changed 4 years ago by aaugustin

  • Component changed from Uncategorized to Core (Other)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Design decision needed
  • UI/UX set

comment:2 Changed 4 years ago by ramiro

Duplicate of #10841

comment:3 Changed 4 years ago by ramiro

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
Back to Top