Code

Opened 3 years ago

Closed 3 years ago

#16097 closed Bug (fixed)

Trac query builder is broken

Reported by: lukeplant Owned by: nobody
Component: *.djangoproject.com Version:
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX:

Description

Steps to reproduce:

  1. Click 'View tickets' above
  2. Click 'Update'

Results:

Exception:

Oops…
Trac detected an internal error:

TypeError: unhashable type: 'list'

File "/home/trac/venv/lib/python2.6/site-packages/trac/web/main.py", line 511, in _dispatch_request
  dispatcher.dispatch(req)
File "/home/trac/venv/lib/python2.6/site-packages/trac/web/main.py", line 237, in dispatch
  resp = chosen_handler.process_request(req)
File "/home/trac/venv/lib/python2.6/site-packages/trac/ticket/query.py", line 918, in process_request
  max)
File "/home/trac/venv/lib/python2.6/site-packages/trac/ticket/query.py", line 73, in __init__
  self.order = synonyms.get(order, order)     # 0.11 compatibility

If you look at the URL - it is crazy long, and seems to have duplicated a lot of info. The duplicated 'order' parameter is apparently the cause of the exception - remove that and it works (but has duplicated columns).

I've tried this in Chrome (while logged in) and Firefox (not logged in) and got the same (though you don't get the traceback if you're not logged in).

This used to work very recently, I don't know what has changed.

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by jezdez

Sigh, I've only added a HTTPS redirect as discussed in the core meeting yesterday. I have no idea how that would trigger that kind of problem, to be honest.

comment:2 Changed 3 years ago by jezdez

  • Resolution set to fixed
  • Status changed from new to closed

Ok, fixed it by using Trac's use_base_url_for_redirect option and setting Front-End-Https header.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.