Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1596 closed defect (duplicate)


Reported by: anonymous Owned by: adrian
Component: Core (Management commands) Version: magic-removal
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


it seemed that the r2611's fix still cause some error.

when i terminate the django buildin server, the console show some information like below:

Django version 0.91 (magic-removal), using settings 'foo.settings'
Development server is running at
Quit the server with CONTROL-C (Unix) or CTRL-BREAK (Windows).
Exception exceptions.AttributeError: "'NoneType' object has no attribute 'print_
exc'" in <function remove at 0x00C80530> ignored

and if i change the django/db/ back to

dispatcher.connect(lambda: connection.close(), signal=signals.request_finished)

the error no longer raised!

my env: windows xp sp2, python 2.4.3, pysqlite2.2.0

Change History (2)

comment:1 Changed 10 years ago by adrian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of [1601].

comment:2 Changed 10 years ago by anonymous

That's probably Ticket #1601, rather than Changeset [1601], right?

Note: See TracTickets for help on using tickets.
Back to Top