Code

Opened 8 years ago

Closed 8 years ago

Last modified 6 months ago

#1601 closed Bug (fixed)

Exception in saferef.py

Reported by: rushman@… Owned by: adrian
Component: Core (Other) Version: magic-removal
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I'm getting exception for all Python scripts that use Django. Exception appears in any script having import of Django models. It happens right after script is finished (before returning to OS).

Exception occurs in saferef.py file, and caused by traceback.print_exc() line.

Exception details:

Exception exceptions.AttributeError: "'NoneType' object has no attribute 'print_
exc'" in <function remove at 0x01F8E570> ignored

My configuration:
Python 2.4, Windows XP 64, Django magic-removal rev. 2633

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by adrian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [2636].

comment:2 Changed 6 months ago by anonymous

  • Easy pickings unset
  • Type changed from defect to Bug
  • UI/UX unset

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.