Code

Opened 3 years ago

Closed 3 years ago

#15934 closed Bug (duplicate)

django sitemaps priority tag not correctly formatted

Reported by: oleiade.nab@… Owned by: nobody
Component: contrib.sitemaps Version: 1.3
Severity: Normal Keywords: sitemaps, google webmaster tool, xml, priority
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX:

Description

hi,

I've noticed that the <priority> tag generated by django sitemaps (GenericSitemap in my case) are of 0,X type instead of 0.X. Which actually seems to impeach google webmaster tools to correctly parse the sitemap.xml.

PS: my settings language is fr-fr.

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

I was discussing this issue with the reporter on IRC, it's obviously a bug.

Localization should be disabled in the template, maybe just for the location field, maybe globally.

comment:2 Changed 3 years ago by aaugustin

  • Resolution set to duplicate
  • Status changed from new to closed

OK, actually the reporter used 1.2 and this was fixed in 1.3. Duplicate of #14164.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.