Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15810 closed New feature (duplicate)

Easy rename of apps in admin

Reported by: aatanasov+django@… Owned by: nobody
Component: contrib.admin Version: master
Severity: Normal Keywords: app_label, admin
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

usage:

from django.contrib.admin.util import AppLabel
class Meta:
    app_label = AppLabel('app_label','Title in admin')


Attachments (1)

dj_adm_add_applabel_class.diff (5.7 KB) - added by aatanasov+django@… 3 years ago.
patch which adds AppLabel to admin used to display app_label in a friendly way

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by aatanasov+django@…

patch which adds AppLabel to admin used to display app_label in a friendly way

comment:1 Changed 3 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #3591. The bigger issue here is app configuration; renaming the app in the admin is just one part of a bigger problem.

comment:2 follow-up: Changed 3 years ago by russellm

I should also add -- #3591 was the subject of a Google Summer of Code project last year, and there's lots of interest in getting that work integrated into trunk in the 1.4 timeframe.

comment:3 in reply to: ↑ 2 Changed 3 years ago by anonymous

The bigger issue here is app configuration; renaming the app in the admin is just one part of a bigger problem.
I should also add -- #3591 was the subject of a Google Summer of Code project last year, and there's lots of interest in getting that work integrated into trunk in the 1.4 timeframe.

I've looked at #3591 before posting this. It's there since 4 years, patch changes a lot of code and tries to solve two problems at once:

  • app paths
  • give apps names

i've tried to solve only the second, minimal changes which are backwards compatible.
result is more like #10436 but with less changes

AppLabel('app_label',_('Translate me'))

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.