Opened 5 years ago

Closed 5 years ago

#15692 closed (duplicate)

"Referenced before assignment" in WSGIHandler

Reported by: sayane Owned by: nobody
Component: Core (Other) Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


This happens when WSGIHandler is not able to decode request data (stupid flash don't know how to encode urls).

Traceback (most recent call last):

  File "/home/sayane/.buildout/parts/django/django/core/servers/", line 283, in run
    self.result = application(self.environ, self.start_response)

  File "/home/sayane/.buildout/parts/django/django/contrib/staticfiles/", line 68, in __call__
    return self.application(environ, start_response)

  File "/home/sayane/.buildout/parts/django/django/core/handlers/", line 264, in __call__
    logger.warning('Bad Request (UnicodeDecodeError): %s' % request.path,

UnboundLocalError: local variable 'request' referenced before assignment

Change History (1)

comment:1 Changed 5 years ago by kmtracey

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15686 and #15672. Please search for an existing ticket before opening a new one.

Note: See TracTickets for help on using tickets.
Back to Top