Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15622 closed (fixed)

TransactionTestCases are broken by django.contrib.contenttypes in 1.2.5

Reported by: zyga Owned by: nobody
Component: Testing framework Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

This issue seems identical to ticket 14975

The missing call to ContentType.objects.clear_cache() is in django.contrib.contenttypes.tests:ContentTypeTests.tearDown

Attachments (1)

fix-15622.patch (412 bytes) - added by zyga 3 years ago.
Patch for this issue

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by zyga

Patch for this issue

comment:1 Changed 3 years ago by russellm

  • Component changed from Uncategorized to Testing framework
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Ready for checkin

Interestingly, I can't reproduce this problem with trunk; only with 1.2.X. However, it's probably worth apply to trunk just in case.

comment:2 Changed 3 years ago by russellm

  • Resolution set to fixed
  • Status changed from new to closed

In [15867]:

Fixed #15622 -- Clear content type cache to avoid problems with subsequence TransactionTestCases. Thanks to zyga for the report

comment:3 Changed 3 years ago by russellm

In [15868]:

[1.2.X] Fixed #15622 -- Clear content type cache to avoid problems with subsequence TransactionTestCases. Thanks to zyga for the report

Backport of r15867 from trunk.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.