Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15520 closed (fixed)

Regression introduced by mail functionality changes from r15669

Reported by: ramiro Owned by: nobody
Component: Core (Mail) Version: master
Severity: Keywords: blocker
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

User dobcey reports that r15669 breaks in Python 2.4. Quoting from his comment:

In 2.4:

from email.generator import Generator

have to be:

from email.Generator import Generator

in order to work. Ie Generator with a capital G.

The problem seems to be that all modules have been renamed according to PEP 8 standards in version 4 of the mail package in Python, as stated here: http://docs.python.org/library/email.html#package-history although it says to be compatible with Python 2.3 to 2.5.

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by ramiro

  • Resolution set to fixed
  • Status changed from new to closed

In [15675]:

Fixed #15520 -- Fixed incompatibility with email module shipped with Python 2.4 introduced in r15669. Thanks dobcey for the report.

comment:2 Changed 3 years ago by ramiro

In [15676]:

[1.2.X] Fixed #15520 -- Fixed incompatibility with email module shipped with Python 2.4 introduced in r15669. Thanks dobcey for the report.

Backport of [15675] from trunk

comment:3 Changed 3 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.