Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15195 closed (wontfix)

TestFramework doesn't set DEBUG to TRUE

Reported by: jbcurtin Owned by: jbcurtin
Component: Testing framework Version: 1.2
Severity: Keywords: test conf debug settings
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Qucikfix:
from django.conf import settings
settings.DEBUG = True
Feel free to tell me were I need to go to register for an account to make the change myself and submit it to the code base.

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to wontfix
  • Status changed from new to closed

This is by design: http://docs.djangoproject.com/en/dev/topics/testing/#other-test-conditions

Regardless of the value of the DEBUG setting in your configuration file, all Django tests run with DEBUG=False. This is to ensure that the observed output of your code matches what will be seen in a production setting.

comment:2 Changed 3 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.