Code

Opened 3 years ago

Closed 3 years ago

#15186 closed (duplicate)

dumpdata needs to load whole tables into memory to dump them

Reported by: Wraithan <xwraithanx@…> Owned by: nobody
Component: Core (Serialization) Version: 1.2
Severity: Keywords: dumpdata
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I was attempting to use dumpdata to dump a 2mil row table so I could import it into another database, when it got to using over 20G of RAM I had to kill it.

The docs should state that it will need to load the whole table and wont serialize as it goes, or dumpdata needs to incrementally write so it doesn't need all the data in memory.

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5423. Please test the latest patch attached there and report back your experiences.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.