Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#15122 closed (fixed)

Template-loader postmortem doesn't offer paths searched anymore

Reported by: rdrey Owned by: nobody
Component: Template system Version: 1.2
Severity: Keywords: regression
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I found a screenshot in the djangobook.com's older 1.0 version that shows a different version of the "Template-loader postmortem", shown here:
http://new-media.djangobook.com/content/en/1.0/chapter04/missing_template.png

The current version (django 1.2+) of the Template-loader postmortem doesn't show the directories checked by the loaders anymore. Why would this have been removed? If this wasn't removed on purpose, it seems to be a bug in django.

I have shown this issue to users in #django and they agree that it is probably a bug.

Change History (3)

comment:1 Changed 5 years ago by ramiro

  • Keywords regression added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

I can confirm I see this in trunk and 1.2.X. The Using loader django.template.loaders.filesystem.Loader: headers are shown but list of template files tried is rendered. Seems to be a 1.2 regression.

comment:2 Changed 5 years ago by ramiro

  • Resolution set to fixed
  • Status changed from new to closed

(In [15252]) Fixed #15122 -- Restored reporting of the template files tried in the texmplate loader post mortem section of the TemplateDoesNotExit 500 error debug page. Thanks rdrey for reporting this regression.

comment:3 Changed 5 years ago by ramiro

(In [15253]) [1.2.X] Fixed #15122 -- Restored reporting of the template files tried in the texmplate loader post mortem section of the TemplateDoesNotExit 500 error debug page. Thanks rdrey for reporting this regression.

Backport of [15252] from trunk

Note: See TracTickets for help on using tickets.
Back to Top