Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14996 closed (duplicate)

Incorrect persistent help_text for ModelMultipleChoiceField if widget is overridden in Modelform class Meta:

Reported by: daryl Owned by: nobody
Component: Forms Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

For example, I have the following:

class SomeAdminModelForm(forms.ModelForm):
    class Meta:
        widgets = {
            'm2m_field': forms.CheckboxSelectMultiple(),
        }

... which alters the m2m field multiple select to a series of checkboxes.

Which is fine, except the help_text is still appended with 'Hold down "Control", or "Command" on a Mac, to select more than one.'

... which is obviously not necessary in this context.

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14402 which report another facet of this problem.

comment:2 Changed 3 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.