Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14982 closed (fixed)

EMPTY_CHANGELIST_VALUE not honored whit a relation field in list_display

Reported by: marcob Owned by: nobody
Component: Uncategorized Version: 1.2
Severity: Keywords: blocker, regression
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

This problem was fixed in #11297 but it came back again with 1.2.4.
Simple patch attached.

Attachments (2)

none_value.11297.1.2.4.diff (912 bytes) - added by marcob 3 years ago.
empty_changelist_value.patch (2.9 KB) - added by sontek 3 years ago.
fixes the issue and has a unit test

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by marcob

comment:1 Changed 3 years ago by russellm

  • Has patch set
  • Needs documentation unset
  • Needs tests set
  • Patch needs improvement set
  • Triage Stage changed from Unreviewed to Accepted

It isn't just 1.2.4 - this existed in 1.2. I'm guessing it's a regression from the introduction of readonly fields.

comment:2 Changed 3 years ago by ramiro

Yes, this is because the triager of #11297 closed it without verifying if the issue reported was effectively fixed.

comment:3 Changed 3 years ago by russellm

  • Keywords blocker, regression added

comment:4 Changed 3 years ago by jezdez

  • milestone set to 1.3

Changed 3 years ago by sontek

fixes the issue and has a unit test

comment:5 Changed 3 years ago by sontek

  • Needs tests unset
  • Patch needs improvement unset

Here is a new patch that solves the issue and has unit tests. It doesn't show up in the preview but if you click original format the patch shows up.

comment:6 Changed 3 years ago by russellm

  • Resolution set to fixed
  • Status changed from new to closed

(In [15286]) Fixed #14982 -- Ensure that EMPTY_CHANGELIST_VALUE is honored for nullable foreign keys. Thanks to marcob for the report and fix, and to sontek for the test case.

comment:7 Changed 3 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.