Code

Opened 3 years ago

Closed 3 years ago

#14883 closed (duplicate)

EmailField should be of type="email"

Reported by: paulc Owned by: nobody
Component: Forms Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I looked around so I hope this isn't a dupe.

With HTML 5 out, EmailField should use an input of type="email" by default. That would be as simple as defining an EmailWidget, like so:

class EmailWidget(forms.widgets.Input):
    input_type = 'email'

And then making EmailField use it:

class EmailField(CharField):
    widget = EmailWidget
    # rest of code...

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by lrekucki

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12488.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.