Opened 5 years ago

Closed 5 years ago

#14882 closed (worksforme)

copy as request param is incorrectly parsed

Reported by: pma_ Owned by: nobody
Component: Core (Other) Version: 1.2
Severity: Keywords: request, parse
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Example request "/xxx/?&id=4&invoice_no=FVS%2F0004%2F12%2F2010&csrfmiddlewaretoken=&org=0&copy=1"

request.GET dict: QueryDict: <QueryDict: {u'org': [u'0\xa9=1'], u'csrfmiddlewaretoken': [u''], u'invoice_no': [u'FVS/0004/12/2010'], u'id': [u'4']}>

org is displayed in debugger as unicode: 0©=1

Change History (1)

comment:1 Changed 5 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this

In [1]: from django.http import QueryDict, HttpRequest

In [2]: q = QueryDict('invoice_no=FVS%2F0004%2F12%2F2010&a=1&b=2&copy=3')

In [3]: q.items()
Out[3]: 
[(u'a', u'1'),
 (u'copy', u'3'),
 (u'invoice_no', u'FVS/0004/12/2010'),
 (u'b', u'2')]

In [4]: q
Out[4]: <QueryDict: {u'a': [u'1'], u'copy': [u'3'], u'invoice_no': [u'FVS/0004/12/2010'], u'b': [u'2']}>

In [5]: q['b']
Out[5]: u'2'

In [6]: q['copy']
Out[6]: u'3'

In [7]:
Note: See TracTickets for help on using tickets.
Back to Top