Opened 5 years ago

Closed 5 years ago

#14852 closed (duplicate)

django.utils.log is incompatible with Python <= 2.5

Reported by: tom@… Owned by: nobody
Component: Uncategorized Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


Line 90 is:

reporter = ExceptionReporter(request, *exc_info, is_email=True)

Which raises a syntax error on Python 2.5 (keyword argument after the * argument) but works fine on Python 2.6.

Changing it to the following has the exact same semantics but should work on all versions:

reporter = ExceptionReporter(request, *exc_info, {"is_email":True})

I'm not sure if I should have attached a diff, but it seemed simpler to just paste it in seeing as it's only 1 line.


Change History (1)

comment:1 Changed 5 years ago by Keryn Knight <keryn@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

I think this is a duplicate of #14851 - please re-open it if I'm mistaken.

Note: See TracTickets for help on using tickets.
Back to Top