Code

Opened 3 years ago

Closed 3 years ago

#14740 closed (duplicate)

CZ Localflavor clean() incorrectly calls parent __init__

Reported by: anonymous Owned by: nobody
Component: contrib.localflavor Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In cz/forms.py, see L54 and L111. At the beginning of clean(), the parent's __init__ is called instead of clean().

Patch attached. Discovered while converting doctests to unittests.

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a dupe of #14741

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.