Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#14679 closed (fixed)

Change of behavior in add new user workflow when using "Save" button

Reported by: ramiro Owned by: nobody
Component: contrib.admin Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: yes Patch needs improvement: no
Easy pickings: UI/UX:

Description

Atr3ides reports in #14014 that r13503 broke the two steps behavior of the user creation flow. When creating a new user and hitting "Save", you are now redirected to User model change list instead of entering editing mode for adding additional user profile.

Attachments (2)

14679.diff (830 bytes) - added by fisadev 4 years ago.
14679_authors.diff (377 bytes) - added by croldan 4 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 4 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Confirmed change in behavior. This also affects the 1.2.X branch.

Changed 4 years ago by fisadev

comment:2 Changed 4 years ago by fisadev

  • Has patch set

Added patch with possible solution.

(fisadev and croldan from PyAr on Rafaela host of Argentina Django sprint 2010)

comment:3 Changed 4 years ago by ramiro

  • Needs tests set
  • Summary changed from Regression in add new user workflow to Change of behavior in add new user workflow when using "Save" button

Summary in table form:

Before r13503:

Button pressed Save and add anotherSave and continue editingSave
Triggered behaviorShows user details Shows user details Shows user details form

After r13503:

Button pressed Save and add another Save and continue editingSave
Triggered behaviorShows brand new user add form (OK, intended fix)Shows use details form Shows User change list (change in behavior)

Changed 4 years ago by croldan

comment:4 Changed 4 years ago by ramiro

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r14628 (trunk) and r14629 (1.2.X branch).

comment:5 Changed 3 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Note: See TracTickets for help on using tickets.
Back to Top