Code

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14546 closed (duplicate)

Queryset docs should drop some legacy Django 1.0 instructions

Reported by: PaulM Owned by: nobody
Component: Documentation Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

http://docs.djangoproject.com/en/1.2/ref/models/querysets/#in

The queryset docs show some roundabout ways to do in lookups, but then have this confusing note:

"Changed in Django 1.1: In Django 1.0, only the latter piece of code is valid."

A user not paying attention is likely to misinterpret this.

We don't need to be teaching users reading the Django 1.3 docs how to build code that's compatible with Django 1.0. The example and the note should be removed.

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by PaulM

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

On second thought, the example probably should stay (shows a useful way of doing things) but the note should go away and that section should possibly be re-ordered a bit to flow more easily.

comment:2 Changed 3 years ago by gabrielhurley

  • Triage Stage changed from Unreviewed to Accepted

comment:3 Changed 3 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14000

comment:4 Changed 3 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.