Opened 5 years ago

Closed 5 years ago

#14530 closed (duplicate)

specify if new translations to django core can be made in project directory

Reported by: ahebert Owned by: nobody
Component: Documentation Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


On the documentation page,, under the title "Locale Restrictions," it says:

If you want to support a locale for your application that is not already part of Django, you’ll need to make at least a minimal translation of the Django core.

A good starting point is to copy the Django English .po file and to translate at least some translation strings.

The text should indicate if the new language .po file may be copied to the project directory, or if it needs to be copied to the Django core source directory (e.g. <python-path>/django/conf/locale/).

Change History (2)

comment:1 Changed 5 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 5 years ago by ramiro

  • Resolution set to duplicate
  • Status changed from new to closed

I will close this as a duplicate of #14461. When that ticket gets solved to not require putting new files under the Django tree to extend the choices of available locales, the respective modifications to the documentation should be included.

Note: See TracTickets for help on using tickets.
Back to Top