Opened 5 years ago

Closed 3 years ago

#14527 closed Cleanup/optimization (fixed)

GeoDjango docs shouldn't recommend PostgreSQL 8.3

Reported by: PaulM Owned by: nobody
Component: Documentation Version: 1.2
Severity: Normal Keywords: GeoDjango
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by gabrielhurley)

The GeoDjango docs recommend using PostgreSQL 8.3 because PostGIS doesn't support 8.4 yet.

I don't believe this is true anymore. PostGIS provides binary windows installers for 8.3, 8.4, and 9.0, and the docs for both the 1.4 and the 1.5 branches claim to be compatible with every version of Postgres from 8.2 and 8.3 respectively.

http://postgis.refractions.net/documentation/manual-1.5/ch02.html#id2576850

http://postgis.refractions.net/documentation/manual-1.4/ch02.html#id2701180

Change History (9)

comment:1 Changed 5 years ago by PaulM

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

That should read "because PostGIS doesn't support Postgres 8.4".

comment:2 Changed 5 years ago by gabrielhurley

  • Description modified (diff)
  • Triage Stage changed from Unreviewed to Accepted

Not being a GeoDjango user myself, I'd like to get someone else to confirm this before it gets fixed, but the report looks correct.

comment:3 Changed 5 years ago by ericpalakovichcarr

I can confirm it. I currently am using PostgreSQL 8.4.5 with PostGIS 1.5.1 for my GeoDjango based web site. Do you need any other kind of proof/sources before the documentation can be updated?

comment:4 Changed 5 years ago by PaulM

The Windows install wizard needs to be updated before this can be fixed. See the recent django-dev thread.

comment:5 Changed 4 years ago by julien

  • Severity set to Normal
  • Type set to Cleanup/optimization

comment:6 Changed 4 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

comment:11 Changed 3 years ago by aaugustin

  • UI/UX unset

Change UI/UX from NULL to False.

comment:12 Changed 3 years ago by aaugustin

  • Easy pickings unset

Change Easy pickings from NULL to False.

comment:13 Changed 3 years ago by claudep

  • Resolution set to fixed
  • Status changed from new to closed

This has been fixed in r15872.

Note: See TracTickets for help on using tickets.
Back to Top