Code

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#14455 closed (fixed)

Document possibly backwards-incompatible localflavor changes

Reported by: kylefox Owned by: nobody
Component: contrib.localflavor Version: master
Severity: Keywords: localflavor, regression, test
Cc: jbronn, kylefox Triage Stage: Accepted
Has patch: no Needs documentation: yes
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

It appears the regression tests were not updated as part of changeset 14195

This patch changes the regression test to use the new provinces in the ID localflavor.

Attachments (1)

patch_14455.diff (3.4 KB) - added by kylefox 4 years ago.

Download all attachments as: .zip

Change History (14)

Changed 4 years ago by kylefox

comment:1 Changed 4 years ago by kylefox

  • Cc jbronn, kylefox added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 4 years ago by kylefox

  • Version changed from 1.2 to SVN

comment:3 Changed 4 years ago by jezdez

  • Triage Stage changed from Unreviewed to Accepted

comment:4 Changed 4 years ago by jezdez

  • milestone set to 1.3

comment:5 Changed 4 years ago by kmtracey

See comment at the end of http://code.djangoproject.com/ticket/13830#comment:4. I don't think changing the 3-letter code is safe at this point. I think the correct fix here is to restore the old 3-letter code and fix the test to recognize the new human-readable name only.

comment:6 Changed 4 years ago by Alex

I seem to recall we had this issue before, anyone good at search or remember the result?

comment:7 Changed 4 years ago by russellm

  • Needs documentation set
  • Patch needs improvement set

Following discussion on IRC with Karen, Alex, Ramiro, SmileyChris and myself:

There is a backwards compatibility issue here, and we can't ignore it. However, by the same token, maintaining displayable lists that contain invalid data (i.e., deprecated, renamed and dissolved provinces) is equally bad.

So - here's the plan:

  • We will document our policy that as a project, we will maintain alignment with officially gazetted municipality lists. If Indonesia deprecates the name, so do we in the next major release, and if an official abbreviation has changed, we'll reflect that change too.
  • We *won't* backport any such change to the stable branch. Micro releases shouldn't affect display/behavior, or require any data migration.
  • When we introduce such a change, we will include it in the release notes as a noteworthy backwards compatibility issue.
  • We will provide a new documentation page that will provide any script/SQL/utility/example that might help with migration process.
  • For the affected release, the module in question will raise a Warning. This ensures that anyone that uses the module and doesn't read the release notes will get notified that there is a problem that needs to be resolved.
  • We will provide a section in the localflavor docs telling people how to silence the warning once they've addressed the issue.

comment:8 Changed 4 years ago by Honza_Kral

Ignorant about this ticket I commited a fix for the tests alone in r14249. There are still issues, as outlined by russelm above this, that need to be resolved.

comment:9 Changed 4 years ago by kmtracey

  • Has patch unset
  • Patch needs improvement unset
  • Summary changed from [patch] Minor regression test fix to Document possibly backwards-incompatible localflavor changes

Change summary to reflect what this ticket is now about. The changes include both the changeset identified here, and r12985 (somewhat belated at this point, but it should still be done).

Also the backport of this Indonesian change (r14196) to the 1.2.X branch should be reverted, along with any test changeset made to fix the test issue (though that does not seem to have been backported yet?), since we have decided it is best not to backport these types of things.

comment:10 Changed 3 years ago by russellm

(In [14410]) [1.2.X] Reverted r14196, restoring the 1.2 test suite to a passing state. Refs #14455.

comment:11 Changed 3 years ago by russellm

  • Resolution set to fixed
  • Status changed from new to closed

(In [14411]) Fixed #14455 -- Documented the backwards compatibility policy for local flavors. Implemented the policy for the changes in the Indonesian local flavor (from r14195) that stimulated the development of this policy. Thanks to Karen, Alex, Ramiro and Chris for their help developing the policy.

comment:12 Changed 3 years ago by russellm

For the record, r14195 was reverted in r14410.

comment:13 Changed 3 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.