Opened 5 years ago

Closed 5 years ago

#14331 closed (duplicate)

Clarify where to append sys.path.append in mod_wsgi docs

Reported by: alist@… Owned by: nobody
Component: Documentation Version: 1.2
Severity: Keywords: deployment
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hey Guys,

Just a quick suggestion with regards to the mod_wsgi deployment, article: http://docs.djangoproject.com/en/1.2/howto/deployment/modwsgi/

Please make the explanation of where to insert the line "sys.path.append('/usr/local/django')" into django.wsgi a bit clearer, as well as the actual path to use, as I was using the path to my project (/home/user/project) rather than what was required (/home/user).

Furthermore, I also suggest adding a suggestion to modify settings.py's specification with regards to admin media to:
"ADMIN_MEDIA_PREFIX = '/admin-media/'", and consequently adding an Alias to httpd.conf to serve admin media, such as:
"Alias /admin-media/ /usr/local/lib/python2.6/dist-packages/Django-1.2.1-py2.6.egg/django/contrib/admin/media/"

Regards,

Alistair Cohen
Beovista Technologies

Change History (2)

comment:1 Changed 5 years ago by gabrielhurley

  • Keywords deployment added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Summary changed from appending $PYTHONPATH to Clarify where to append sys.path.append in mod_wsgi docs
  • Triage Stage changed from Unreviewed to Accepted

Splitting that explanation across two lines is bad for readability. That docs page could use a thorough review. There are several related tickets, all now tagged with the keyword "deployment".

comment:2 Changed 5 years ago by timo

  • Resolution set to duplicate
  • Status changed from new to closed

More or less a duplicate of #14277

Note: See TracTickets for help on using tickets.
Back to Top