Code

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#14329 closed (duplicate)

Seeing test failure in regressiontests.request since 13809

Reported by: gabrielhurley Owned by: gabrielhurley
Component: HTTP handling Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I'm getting the following test failure when I run the test suite using sqlite on Windows XP with Python 2.6.5 since [13809]:

======================================================================
FAIL: Doctest: regressiontests.requests.tests
----------------------------------------------------------------------
File "[...]\django-trunk\tests\regressiontests\requests\tests.py
", line 55, in regressiontests.requests.tests
Failed example:
    datetime_cookie['max-age']
Expected:
    10
Got:
    11

I don't have time to dig into it at the moment, but I'm guessing it's a timezone-related issue or something of the sort.

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 4 years ago by gabrielhurley

  • Owner changed from nobody to gabrielhurley
  • Status changed from new to assigned

yay! glad I'm not crazy.

I have the feeling the best solution here is just to convert that test to a unit test and use a less naive comparison for the max_age value... (we have always been at war with doctests)

comment:3 Changed 4 years ago by lukeplant

  • Resolution set to duplicate
  • Status changed from assigned to closed

Dupe of #14351

comment:4 Changed 3 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.