Opened 4 years ago

Closed 4 years ago

#14278 closed (worksforme)

sqlite3 backend and django 1.2.3, bug: «no such table»

Reported by: cld Owned by: nobody
Component: Database layer (models, ORM) Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I such start a new project, and like all new project I start I take a new django version...

Write some models and for all of them in administration page I got a
Exception Type: DatabaseError
Exception Value: no such table: appsname_modelsname

With the dbshell, it's ok, table exist and with python shell I can create/delete/update object without problem.

Retest with completly clean and simple models:
http://pastebin.com/z1wgBWYC
(Well I don't know how to made simpler :))

Same error.

I had tested on Django 1.2.1, it's works. Not tested (yet) with other database backend.

Change History (3)

comment:1 Changed 4 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Using exactly this example (thanks so much for a simple example, btw), I couldn't repeat the problem. I created an empty project, filled in testbug/, added it and admin to settings, added admin to urls.py and ran syncdb and viewed /admin/ in the browser. No problems when adding a TestBug entry.

So what step are you doing differently? I'd be *very* surprised if this really was a general bug, since even in the two days since 1.2.3 was announced, we would have heard about it, but please verify which step above is different in your situation.

comment:2 Changed 4 years ago by Cld

...
After multiple test and reproduction of the bug I reboot the development server computer and... It's works :/

comment:3 Changed 4 years ago by kmtracey

  • Resolution set to worksforme
  • Status changed from new to closed

So this sounds like it was some sort of machine configuration issue.

Note: See TracTickets for help on using tickets.
Back to Top