Opened 5 years ago

Closed 5 years ago

Last modified 11 months ago

#14136 closed Uncategorized (duplicate)

Show how to specify schemas for Oracle databases

Reported by: pfctdayelise Owned by: nobody
Component: Documentation Version: 1.2
Severity: Normal Keywords: databases oracle easy
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

As mentioned here, to specify a schema as well as a db_table for an Oracle database, you need to do some fancy quoting like this:

    class Meta:
        db_table = u'"SCHEMA"."TABLE_NAME"'

It would be nice to mention that in the docs. I spent ages trying to figure it out!

Change History (3)

comment:1 Changed 5 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Closing this ticket as a duplicate of #6148 following the rationale used by Russell when closing #14203 and explained there.

comment:2 Changed 12 months ago by mike.henken@…

  • Easy pickings unset
  • Severity set to Normal
  • Type set to Uncategorized
  • UI/UX unset

Please add to documentation. I too spent quite some time looking for this.

comment:3 Changed 11 months ago by anonymous

If you want to argue about a closed ticket, please go to the developers list.

Note: See TracTickets for help on using tickets.
Back to Top