Code

Opened 4 years ago

Closed 4 years ago

#13881 closed (duplicate)

Sitemaps are broken by L10N

Reported by: farcaller Owned by: nobody
Component: Contrib apps Version: master
Severity: Keywords: sitemaps, l10n
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

If you enable L10N with some locale that doesn't use "." as decimal separator (e.g. "ru" switches it to ","), sitemaps become broken: <priority> tag is L10N-ized.

Attachments (3)

13881.tests.patch (2.6 KB) - added by gregmuellegger 4 years ago.
Creating regressiontestmodule for sitemaps application and failing tests for the descriptions in the ticket.
13881.tests_and_fix.patch (3.5 KB) - added by gregmuellegger 4 years ago.
Same tests as in first patch, but now includes a simple fix for the issue.
13881.tests_and_fix2.patch (3.4 KB) - added by gregmuellegger 4 years ago.
"refactored" patch.

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by gregmuellegger

Creating regressiontestmodule for sitemaps application and failing tests for the descriptions in the ticket.

Changed 4 years ago by gregmuellegger

Same tests as in first patch, but now includes a simple fix for the issue.

comment:1 Changed 4 years ago by gregmuellegger

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted
  • Version changed from 1.2 to SVN

I can confirm that this issue exists.

Tests and a fix are attached.

Changed 4 years ago by gregmuellegger

"refactored" patch.

comment:2 Changed 4 years ago by anonymous

Looks like duplicate #13617

comment:3 Changed 4 years ago by mk

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of (fixed) #14164

#14181 targets broader issue of L10N formatting of numbers/variables.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.