Opened 5 years ago

Closed 4 years ago

#13855 closed New feature (wontfix)

urlresolvers' resolve does not work on URLs with query string

Reported by: mitar Owned by: nobody
Component: Core (Other) Version: 1.2
Severity: Normal Keywords:
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no


urlresolvers' resolve does not work on URLs with query string passed as an argument. I think it should silently ignore query string the same as URL dispatching does not take into the account query string. The problem is obviously in that those functions work on request.path but I think they should work also on request.get_full_path.

Change History (3)

comment:1 Changed 5 years ago by lrekucki

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Design decision needed

comment:2 Changed 5 years ago by graham_king

  • Severity set to Normal
  • Type set to New feature

comment:3 Changed 4 years ago by SmileyChris

  • Easy pickings unset
  • Resolution set to wontfix
  • Status changed from new to closed
  • UI/UX unset

request.path could contain a question mark as part of the path.

For example, http://localhost:8000/test%3f results in request.path containing /test?.

On those grounds, I'm closing this ticket as wontfix due to breaking backwards compatibility in a very rare, but reproducible way.

Note: See TracTickets for help on using tickets.
Back to Top