Opened 5 years ago

Closed 5 years ago

#13852 closed (duplicate)

Add AUTOINCREMENT on Sqlite table creation

Reported by: a427137 Owned by: nobody
Component: Database layer (models, ORM) Version: 1.2
Severity: Keywords: sqlite
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


When i select sdlite3 db engine, id field on objects are converted in:


but this definition cause the reuse of canceled "id" on table (see )

Adding AUTOINCREMENT in "id" definition statement, will make the same behavior on pgsql, mysql and sqlite engine.

Change History (1)

comment:1 Changed 5 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10164.

Note: See TracTickets for help on using tickets.
Back to Top