Opened 5 years ago

Closed 4 years ago

#13647 closed (duplicate)

Duplicated import of deepcopy in django.db.models.query

Reported by: DaNmarner Owned by: nobody
Component: Database layer (models, ORM) Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Obviously deepcopy is being imported twice from copy and copycompat...so the legacy code should be gone.

Attachments (1)

no_dup_import_deepcopy.diff (390 bytes) - added by DaNmarner 5 years ago.
Removes the dup of deepcopy import

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by DaNmarner

Removes the dup of deepcopy import

comment:1 Changed 5 years ago by lrekucki

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

The line was added in r11952 so this is also present in 1.2.X. In Python 2.5 the copycompat module is no longer needed and could be removed at all.

comment:2 Changed 4 years ago by mk

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14280

Note: See TracTickets for help on using tickets.
Back to Top