Code

Opened 4 years ago

Closed 4 years ago

#13501 closed (duplicate)

Can't use urlresolvers.reverse() during Feed initialization

Reported by: gmandx Owned by: nobody
Component: contrib.syndication Version: master
Severity: Keywords: Feed resolve URLConf circular dependency
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

To provide a link attribute to Feed subclasses, django.core.urlresolvers.reverse can't be used to provide that value, since Feed instances are created during URLConf initialization, so there is nothing to reverse yet. To use resolve to retrieve this value, a link(self) method must be used, so reverse is called after URLConf init. This circular dependency is likely to be hard to solve, but at least must be documented, since no errors than NoReverseMatch are thrown.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #11712.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.