Opened 5 years ago

Closed 5 years ago

#13375 closed (duplicate)

django model validation error

Reported by: davisd Owned by: nobody
Component: Database layer (models, ORM) Version: master
Severity: Keywords: models, model validation
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I'm having a problem with django svn 12995 that does not exist in 12852. It appears that model validation is broken...

Start a django project 'testme':

 startproject testme

inside testme Start an app 'testapp':

 manage.py startapp testapp

edit testme/settings.py and add to installed applications:

 'django.contrib.comments',
 'testapp',

inside testme/testapp/models.py, simply add:

 from django.contrib.comments.models import Comment

Run anything that validates models (syncdb, shell, etc):

 run manage.py shell

Will show the model validation error:

 error: cannot import name Comment

This worked in svn 12852 but is broken in 12995

Since the comments framework was last changed before 12852, I believe it is in the model validation.

Change History (4)

comment:1 follow-up: Changed 5 years ago by davisd

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Looks like it happend in revision 12976

comment:2 in reply to: ↑ 1 Changed 5 years ago by davisd

Replying to davisd:

Looks like it happend in revision 12976

sorry, it happened in 12977, not 12976.

comment:3 Changed 5 years ago by russellm

Duplicate of #13372

comment:4 Changed 5 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
Back to Top