Code

Opened 4 years ago

Closed 4 years ago

#13281 closed (duplicate)

readonly_fields from auth admin user/group panel

Reported by: haras Owned by: nobody
Component: contrib.auth Version: master
Severity: Keywords: crud
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

since there is a field called readonly_fields
why there is no option to select from admin panel auth model user/group readonly permission, for example there is few users, who can only read data, without making any changes
there is a solution
http://stackoverflow.com/questions/1336382/how-can-i-modify-django-to-create-view-permission
I think CRUD perms are essential not only CUD

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Adding the ability to have a read-only role in the admin is a topic that re-appears from time to time.

See the '"When and Why to Use the Admin Interface — And When Not to"' section.of http://djangobook.com/en/2.0/chapter06/ for a verbose explanation about the target users of the admin app.

There are several discussions in mailing lists (see http://groups.google.com/group/django-users/browse_frm/thread/4dec61582bbf5c44/44e4b82c116291c1?hl=en&lnk=gst&q=read+only+django+admin#44e4b82c116291c1 and https://mail.google.com/mail/#search/admin+read+only/1235e9a2a8f6e924 for a couple of examples) about this and similar tickets that were closed (e.g. #820, #7150) on this basis.

Closing a a duplicate of #820.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.