Opened 5 years ago

Closed 5 years ago

#13255 closed (duplicate)

HTML5 Multiple File upload support

Reported by: Ciantic Owned by: nobody
Component: Forms Version:
Severity: Keywords: html5
Cc: Ciantic Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Django backend does not support multiple file field in HTML5, currently implemented by Chrome.

Here is excerpt of HTML5 how it is done:

<form action='#' method='post' enctype='multipart/form-data'>
  <input name='uploads' type=file multiple>
  <input type='submit'>
</form>

I have not tested what happens in Django when using above, but nevertheless there should be new form fields and model fields for this.

More details see blog post uploading multiple files using html5 and W3 File Upload State.

Change History (1)

comment:1 Changed 5 years ago by kmtracey

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12446.

Note: See TracTickets for help on using tickets.
Back to Top