Code

Opened 4 years ago

Closed 4 years ago

#13243 closed (duplicate)

'NoneType' object has no attribute 'get'

Reported by: rif Owned by: nobody
Component: Uncategorized Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by kmtracey)

I get a crash using one of my project if I am using the latest svn version. If I switch to 1.2 beta-1 the submission works fine.
When I submit a form in admin I get the following error:

'NoneType' object has no attribute 'get'
Request Method:	POST
Request URL:	http://localhost:8000/admin/pontaj/absenta/add/
Django Version:	1.2 beta 1 SVN-12881
Exception Type:	AttributeError
Exception Value:	
'NoneType' object has no attribute 'get'
Exception Location:	/Users/rif/.virtualenvs/carpeDiem/lib/python2.6/site-packages/django/forms/models.py in _get_validation_exclusions, line 303
Python Executable:	/Users/rif/.virtualenvs/carpeDiem/bin/python
Python Version:	2.6.1
Python Path:	['/Users/rif/Documents/webframeworks/carpeDiem', '/Users/rif/.virtualenvs/carpeDiem/lib/python2.6/site-packages/pip-0.6.1-py2.6.egg', '/Users/rif/.virtualenvs/carpeDiem/lib/python26.zip', '/Users/rif/.virtualenvs/carpeDiem/lib/python2.6', '/Users/rif/.virtualenvs/carpeDiem/lib/python2.6/plat-darwin', '/Users/rif/.virtualenvs/carpeDiem/lib/python2.6/plat-mac', '/Users/rif/.virtualenvs/carpeDiem/lib/python2.6/plat-mac/lib-scriptpackages', '/Users/rif/.virtualenvs/carpeDiem/Extras/lib/python', '/Users/rif/.virtualenvs/carpeDiem/lib/python2.6/lib-tk', '/Users/rif/.virtualenvs/carpeDiem/lib/python2.6/lib-old', '/Users/rif/.virtualenvs/carpeDiem/lib/python2.6/lib-dynload', '/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6', '/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/plat-darwin', '/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/lib-tk', '/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/plat-mac', '/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/plat-mac/lib-scriptpackages', '/Users/rif/.virtualenvs/carpeDiem/lib/python2.6/site-packages']
Server time:	Mon, 29 Mar 2010 22:31:34 +0300

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by kmtracey

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

[Reformatted description. Please use preview.]

Please use WikiFormatting and please post the full contents of the text box when you press "switch to copy-and-paste view" -- what has been included here is not enough to give anyone much of an idea what might be going wrong. Some specifics of what form(s) in admin, exactly, would be helpful.

comment:2 Changed 4 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed

I'm closing this as a duplicate of #13197. It's the same error message, reported by the same user, and they didn't provide any specifics there, either. However, another user managed to duplicate the problem by failing to return corrected in their clean() method. That's enough for me to call this a case of user error.

@rif - If you're reporting errors, you have to tell us *how* you generated the error. The stack trace by itself doesn't help us very much.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.