Code

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#13232 closed (duplicate)

Whitespace Bug in URL Tag for password_reset_email.html

Reported by: paltman Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords: registration, admin, email
Cc: paltman@… Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In django.contrib.admin.templates.registration the password_reset_email.html was modified from ticket #8129. Granted it's been almost two years, but I hit this bug yesterday running on django trunk, when it complained about a malformed url tag.

It appears all it is is a space in the kwargs to the tag.

Maybe I am the only one experiencing this for some odd reason, but I was running a clean environment with latest checkout from trunk and removing the space alleviated the exception.

Attachments (1)

django_contrib_admin_password_reset_email_url_tag_bug.diff (760 bytes) - added by anonymous 4 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

I'm pretty sure this is a duplicate of #12945; the tag syntax is fine (if deprecated), but the url tag has changed in an incompatible way recently.

comment:2 Changed 3 years ago by jacob

  • milestone 1.2 deleted

Milestone 1.2 deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.