Opened 5 years ago

Closed 5 years ago

#13194 closed (duplicate)

Django test client can't store cookies after upgrade to Python 2.6.5

Reported by: Oleksiy Solyanyk <solex@…> Owned by: nobody
Component: Testing framework Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

After upgrading to Python 2.6.5, Django test client is storing malformed cookies, thus not allowing to test anything session-related

The error is relatively hard to track, as no exception is raised by DB session backend.
File-based session backend raises

SuspiciousOperation: Invalid characters (directory components) in session key

It looks like the error is caused by the change to Cookie module introduced here: http://svn.python.org/view/python/trunk/Lib/Cookie.py?r1=71029&r2=74647

Not sure if this change affects other libraries.

Change History (2)

comment:1 Changed 5 years ago by Oleksiy Solyanyk <solex@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Summary changed from Python 2.6.5 breaks Django test client's ability to store cookies to Django test client can't store cookies after upgrade to Python 2.6.5

comment:2 Changed 5 years ago by ramiro

  • Resolution set to duplicate
  • Status changed from new to closed

Seems like a duplicate of #12720 that was fixed in [12343] (trunk) and [12344] (1.1.X branch, post 1.1.1)

Note: See TracTickets for help on using tickets.
Back to Top